Author Topic: new carlton, back behind the wheel!  (Read 569 times)

Sutty2006

  • Newbie
  • *
  • Posts: 44
new carlton, back behind the wheel!
« on: March 01, 2018, 09:10:54 AM »
Last night I picked up another Carlton. Been after this one for a while and at a seriously reduced price from last year, it was rude not to. I sold my cavalier yesterday morning then picked this up in the evening. 2.3TD. Love it.



« Last Edit: March 01, 2018, 09:12:41 AM by Sutty2006 »

0795omega

  • Hero Member
  • *****
  • Posts: 520
Re: new carlton, back behind the wheel!
« Reply #1 on: March 01, 2018, 09:36:39 PM »
good to hear that is it smoke grey? was a nice one on e-bay about a week ago looked very tidy!

Sutty2006

  • Newbie
  • *
  • Posts: 44
Re: new carlton, back behind the wheel!
« Reply #2 on: March 08, 2018, 07:54:36 PM »
Yep thats the one. Struggling to get pictures up. Its got the original wheels on it now (much better). Ive got an issue with fuel leaking from the return pipes on the diesel engine. Its like theres too much pressure in the return line, have stripped the PRV off the filter and it seams to be OK. I could do with some more info on these engines as there doesnt appear to be any information readily available.

Dave the Builder

  • Wanted: Life
  • ******
  • Posts: 3445
  • Swadlincote,Derbyshire
Re: new carlton, back behind the wheel!
« Reply #3 on: March 09, 2018, 07:10:55 PM »
is it worth running a temporary return to rule out the return line is not blocked or crushed ?
not familiar with the diesel plant ,all mine have been  "4 bangers" (2.0 L ,4 cylinder petrol lumps)
If the above post contains spelling mistakes / grammatical errors / poor use of the quote function / a very weak retort, or is generally shyte; it's because I'm feked on a cocktail of drugs,homebrew and carb cleaner.sorry

Sutty2006

  • Newbie
  • *
  • Posts: 44
Re: new carlton, back behind the wheel!
« Reply #4 on: March 10, 2018, 03:39:28 PM »
Well ive been racking my brains for days on this issue. Ive cleared the return pipe to the tank. Ive found the return pipe from the pump had a plastic T piece (but with an extra pipe outlet) that had been blocked off (presumably broken and sealed) and the number 4 return pipe plumbed direct to the PR Valve on the filter. Now I need to find a new piece, or fix this one.